To view uptime history for your instance of Canvas, click here.

Slow running Imports and Exports
Incident Report for Instructure
Resolved
All of the queued jobs requests have been processed, Canvas jobs (imports and exports) are returned to expected performance. Thank you for your patience while we put things back in order.
Posted Mar 08, 2018 - 05:03 MST
Update
The jobs service has completed about half of the queued, slow, requests at this time. We expect that Canvas jobs will return to normal shortly.
Posted Mar 08, 2018 - 04:51 MST
Monitoring
Canvas import and exports are starting to catch up and process faster. We expect this to return to normal shortly.
Posted Mar 08, 2018 - 04:29 MST
Investigating
Imports and Export jobs are running slowly in Canvas. We are investigating a cause and will update shortly.
Posted Mar 08, 2018 - 04:19 MST