To view uptime history for your instance of Canvas, click here.

EU and UK based users are experiencing slowness within Canvas.
Incident Report for Instructure
Resolved
Canvas users in the EU and UK are experiencing slowness and intermittent page errors in Canvas. We were able to resolve this at 8:00 am MST. Our Operations team was able to investigate, identify, and resolve the issue. We appreciate your patience, and apologize for any inconvenience this may have caused.
Posted Dec 13, 2017 - 11:06 MST
Identified
Canvas users in the EU and UK are experiencing slowness and slow page loading times within Canvas. Our Operations team is currently investigating this. We appreciate your patience, and apologize for any inconvenience this is causing.
Posted Dec 13, 2017 - 07:57 MST