Some users in North America may be experiencing slow page load times
Incident Report for Canvas
Resolved
Our DevOps Team has Identified and resolved the slow page load times. We apologize for any inconvenience caused.
Posted 14 days ago. Sep 05, 2018 - 12:33 MDT
Investigating
Canvas users in North America may be experiencing slow page load times when using Canvas. Our DevOps team is aware and investigating. We apologize for any inconvenience caused.
Posted 15 days ago. Sep 05, 2018 - 10:39 MDT
This incident affected: Canvas.