Some users are experiencing long load times when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Apr 20, 2020 - 11:33 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 20, 2020 - 11:18 MDT
Investigating
We are currently investigating this issue.
Posted Apr 20, 2020 - 11:03 MDT
This incident affected: Canvas (Canvas).