To view uptime history for your instance of Canvas, click here.

Cisco users may be experiencing slow page load times and 504 timeouts
Incident Report for Instructure
Resolved
Our DevOps Team has resolved the slow page load times and Canvas service for all Cisco users has resumed. Thank you for your patience.
Posted Mar 15, 2018 - 07:32 MDT
Update
The DevOps team are still investigating the slow page load times and 504 Timeouts. We apologize for any inconvenience caused.
Posted Mar 15, 2018 - 07:23 MDT
Investigating
Some of our Cisco users may be experiencing slow page load times and 504 timeouts. Our DevOps team is aware and is working to resolve this. We apologize for any inconvenience caused.
Posted Mar 15, 2018 - 06:08 MDT