To view uptime history for your instance of Canvas, click here.

A small subset of users are experiencing slowness or page errors when accessing Canvas
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Aug 04, 2020 - 11:51 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 04, 2020 - 11:36 MDT
Identified
Our DevOps team have identified the cause, and are currently working on a fix. We'll provide another update in a few minutes.
Posted Aug 04, 2020 - 11:33 MDT
Investigating
We're seeing that a small subset of users are experiencing slowness or page errors when accessing Canvas. Our DevOps team is currently investigating the issue, we'll provide an update shortly.
Posted Aug 04, 2020 - 11:20 MDT
This incident affected: Canvas (Canvas).