Page errors and slow load times
Incident Report for Canvas
Resolved
Our DevOps team have identified the issue and deployed a fix that has resolved the slowness being experienced by users.
Posted 3 months ago. Jul 30, 2018 - 12:19 MDT
Investigating
We are aware of page errors and slow load times affecting a small portion of US-based users. Our DevOps team is working on resolving this issue. We apologize for any disruption experienced by your users.
Posted 3 months ago. Jul 30, 2018 - 12:07 MDT
This incident affected: Canvas.