To view uptime history for your instance of Canvas, click here.

Document previews intermittently rendering in Canvas
Incident Report for Instructure
Resolved
Our engineers have reported that Canvas documents are rendering normally once again. We appreciate your patience during these periods of latency, and we're truly sorry for any inconvenience this situation might have caused you. Thank you.
Posted Apr 11, 2017 - 13:59 MDT
Update
Our engineers have been utilizing more resources throughout the day in order to rectify the high number of documents that need to be processed for Canvas previewing. It has been making an impact, but overall users are still experiencing higher delays than is acceptable. We are continuing to investigate the cause of the latency with Canvas documents and we'll post another update shortly. Thank you for your continued patience.
Posted Apr 11, 2017 - 11:41 MDT
Update
We're continuing to process document for previewing as fast as possible, but there is still a large amount of documents left to render. Although the volume of documents is trending in a positive direction, some users may still run into delays with their documents previewing in Canvas. We will post another update shortly once we have further information. Thank you for your continued patience.
Posted Apr 11, 2017 - 08:16 MDT
Monitoring
The issue has been identified and a resolution is being applied. Some users may still experience a degraded service when rendering files in Canvas as we continue to monitor the issue.
Posted Apr 11, 2017 - 03:06 MDT
Investigating
Some users are unable to preview files in Canvas. Our engineers are currently looking into this, we will provide additional updates as information becomes available to us. We apologize for any inconvenience this may be causing.
Posted Apr 11, 2017 - 00:51 MDT