To view uptime history for your instance of Canvas, click here.

A small amount of users are unable to access Canvas
Incident Report for Instructure
Resolved
Our DevOps team was able to locate the cause of this behavior and implement a solution. Again, we apologize for any inconvenience this may have caused your users.
Posted Nov 15, 2017 - 14:10 MST
Investigating
A small percentage of users may be experiencing slow page load times or timeout errors when trying to access Canvas. Our DevOps team is looking into the cause of this behavior. We are very sorry for any inconvenience this may be causing.
Posted Nov 15, 2017 - 13:51 MST