To view uptime history for your instance of Canvas, click here.

Jobs Requests Slow to Process
Incident Report for Instructure
Resolved
Our team was able to resolve these troubles. Requests have been working through and are processing at a normal rate. Thank you for your patience while we investigated this and corrected the behavior.
Posted Jan 21, 2020 - 11:16 MST
Monitoring
Our team found the cause of the queued jobs requests. They are implementing some actions to process through the queued requests. We will continue to monitor the job queue, to ensure it continues improving.
Posted Jan 21, 2020 - 10:29 MST
Investigating
We have received reports that users are noticing slower than normal processing times within some areas of Canvas. Our devops team is currently investigating the cause to this and looking to implement a fix.
Posted Jan 21, 2020 - 10:05 MST
This incident affected: Canvas (Canvas LMS).