To view uptime history for your instance of Canvas, click here.

Some users are seeing 504 timeout errors when uploading or downloading files in Canvas
Incident Report for Instructure
Resolved
Our Engineering Team has found and resolved the issue. Users are now able to able to upload and download files in Canvas
Posted Aug 27, 2018 - 14:45 MDT
Monitoring
Our Engineering Team has found and resolved the root cause of this issue. We will continue to monitor this situation to ensure that there are no further issues. Thank you for your continued patience.
Posted Aug 27, 2018 - 14:30 MDT
Update
We are still investigating the 504 errors when uploading or downloading files within Canvas. Our Engineering team is working to resolve this issue. We will provide a new update within the next 30 minutes.
Posted Aug 27, 2018 - 14:03 MDT
Investigating
We are aware of page errors and users seeing 504 errors when uploading or downloading files in Canvas. Our Engineering team is working to resolve this issue. We apologize for any disruption experienced by your users.
Posted Aug 27, 2018 - 12:36 MDT