To view uptime history for your instance of Canvas, click here.

Some users may be unable to access the O365 app
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Aug 17, 2020 - 09:49 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 17, 2020 - 09:28 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 17, 2020 - 08:39 MDT