To view uptime history for your instance of Canvas, click here.

Some our US based Canvas users may be experiencing slow load times or page time outs
Incident Report for Instructure
Resolved
Our DevOps team identified the issue and Canvas has resumed normal service. Thank you for your patience and we apologize for any inconvenience.
Posted May 15, 2018 - 07:14 MDT
Monitoring
Some users in Canvas may have experienced slow load times and even page timeouts when trying to access pages within Canvas. Our DevOps team quickly diverted traffic to assist with the load to prevent the issue from extending further. We will continue to monitor this.
Posted May 15, 2018 - 07:02 MDT
Investigating
We are aware of slow load times affecting a small portion of US-based users. Our DevOps team is working on resolving this issue. We apologize for any disruption experienced by your users.
Posted May 15, 2018 - 06:33 MDT
This incident affected: Canvas (Canvas LMS).