Some Canvas users are unable to upload or download files to Canvas
Incident Report for Canvas
Resolved
Our engineers were able to fix the issue and uploads and downloads should be working as intended.
Posted 22 days ago. Oct 29, 2018 - 10:32 MDT
Identified
Our engineers have identified what caused the issue. They are currently working on a fix. We have seen improvements but will continue to update you as more information becomes available.
Posted 22 days ago. Oct 29, 2018 - 09:34 MDT
Investigating
We are aware of an issue that is preventing some Canvas users from uploading or downloading files to and from Canvas.
Posted 22 days ago. Oct 29, 2018 - 08:52 MDT
This incident affected: Canvas, — Document previewing, and — Imports and exports.