To view uptime history for your instance of Canvas, click here.

Some users experiencing page time outs while trying to access Canvas
Incident Report for Instructure
Resolved
From 9:26AM MST to 10:04AM MST, users experienced intermittent access when trying to load pages within Canvas, which resulted in page errors being displayed. Our DevOps team was able to identify and resolve the issue. We apologize for any inconvenience this has caused
Posted Jan 06, 2018 - 10:41 MST
Identified
Some users are experiencing intermittent access when trying to load pages within Canvas resulting in page errors being displayed. Our DevOps team has identified the issue, and is currently working to deploy a fix. We apologize for any inconvenience this has caused.
Posted Jan 06, 2018 - 09:48 MST