To view uptime history for your instance of Canvas, click here.

Some US based users experiencing page errors when accesses Canvas.
Incident Report for Instructure
Resolved
Our Devops team was able to quickly identify and resolve the issue. Users should be able to access Canvas.
Posted Jun 07, 2021 - 09:29 MDT
Investigating
Some users are getting a page error when trying to access Canvas. Our DevOps team is investigating the issue.
Posted Jun 07, 2021 - 09:26 MDT
This incident affected: Canvas (Canvas LMS).