To view uptime history for your instance of Canvas, click here.

Users in the EU/Dublin region are experiencing slowness when accessing Canvas
Incident Report for Instructure
Resolved
This morning we rolled out a change to our load balancing configuration for the EU/Dublin region which resulted in intermittent errors and timeouts. We have reverted the change fully now and things are back to how they were this morning and yesterday. We have made this same change in other clusters with success. We are investigating this and will monitor performance and error rates closely and will make some changes to how we roll this change out that will mitigate the problems.
This occurred today between 9:46 am and 6:07 pm MDT. Thank you for your patience during this time.
Posted Apr 29, 2017 - 20:55 MDT
Monitoring
Our DevOps team has rolled back the changes that were made this morning and the errors and latency have improved. We will continue to monitor this.
Posted Apr 29, 2017 - 20:41 MDT
Investigating
Users in the EU/Dublin region are currently experiencing issues when accessing Canvas. Our DevOps team is working to resolve this issue as quickly as possible. We are currently reverting changes that were made this morning and verifying that the symptoms we can see will revert back to normal. We apologize for any trouble this is causing for you today, and appreciate your patience as we investigate the issue.
Posted Apr 29, 2017 - 18:58 MDT