To view uptime history for your instance of Canvas, click here.

Page errors when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Oct 30, 2021 - 18:13 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 30, 2021 - 18:03 MDT
Investigating
Our team is investigating an issue that is causing a small number of users to experience request timeout errors when accessing Canvas.
Posted Oct 30, 2021 - 17:47 MDT
This incident affected: Canvas (Canvas LMS).