To view uptime history for your instance of Canvas, click here.

Connectivity issues for Canvas 9:22 and 9:31 pm MST
Incident Report for Instructure
Resolved
The issue has been resolved.
Posted Sep 05, 2017 - 21:59 MDT
Monitoring
Resolved - Some Canvas Users were unable to access Canvas between 9:22 and 9:31 pm MST. Our DevOps team has ensured the site is available and running normally now. We apologize for the interruption.
Posted Sep 05, 2017 - 21:58 MDT