To view uptime history for your instance of Canvas, click here.

Page errors and slow load times
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jul 17, 2018 - 11:32 MDT
Update
Our DevOps team was able to isolate the cause and resolve the issue. Thank you for your patience and we apologize for any inconvenience this may have caused your users.
Posted Jul 17, 2018 - 11:31 MDT
Investigating
We are aware of page errors and slow load times affecting a small portion of US-based users. Our DevOps team is working on resolving this issue. We apologize for any disruption experienced by your users.
Posted Jul 17, 2018 - 11:15 MDT