To view uptime history for your instance of Canvas, click here.

Canvas Users in North America may be experiencing some slow page load times.
Incident Report for Instructure
Resolved
Our DevOps team has identified the issue and Canvas has resumed normal service. Thank you for your patience and we apologize for any inconvenience.
Posted Mar 27, 2018 - 07:13 MDT
Investigating
Canvas Users in North America may be experiencing some slow page load times. Our DevOps team is currently investigating the issue. We apologize for any inconvenience caused.
Posted Mar 27, 2018 - 07:12 MDT