To view uptime history for your instance of Canvas, click here.

A small number of Canvas users are experiencing longer load times
Incident Report for Instructure
Resolved
The small number of affected users can now expect normal Canvas performance again. Thank you for your patience.
Posted Feb 06, 2019 - 10:42 MST
Update
We are continuing to monitor for any further issues.
Posted Feb 06, 2019 - 10:19 MST
Monitoring
Canvas performance is improving for impacted users. We are continuing to monitor to ensure there's no further issues. We apologize for the inconvenience.
Posted Feb 06, 2019 - 10:17 MST
Investigating
A small number of Canvas users may be experiencing longer load times than normal. Our engineers are currently reviewing potential causes, as well as any mitigation options. Thank you for your patience.
Posted Feb 06, 2019 - 09:56 MST
This incident affected: Canvas (Canvas LMS).