To view uptime history for your instance of Canvas, click here.

Some users are experiencing "This website is under heavy load (queue full)"
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Aug 27, 2021 - 08:01 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 27, 2021 - 07:14 MDT