To view uptime history for your instance of Canvas, click here.

Intermittent Degraded Performance for U.S. Customers
Incident Report for Instructure
Resolved
Our DevOps team was able to implement a fix for this slowness. We apologize again for this behavior and appreciate your patience while we worked to mitigate this situation.
Posted Sep 13, 2017 - 18:51 MDT
Update
Some users may still be experiencing slowness and timeout errors while accessing Canvas. We appreciate your patience as our DevOps team is working diligently to identify the root cause of the issue. We'll keep you updated as more information becomes available.
Posted Sep 13, 2017 - 13:46 MDT
Investigating
Canvas users in the U.S. may be experiencing intermittent slowness and timeout errors. Our DevOps team is working on a fix to resolve these performance issues your users may encounter. We'll post an update here as soon as it is available.
Posted Sep 13, 2017 - 11:27 MDT