To view uptime history for your instance of Canvas, click here.

A small amount of users maybe experiencing long load times when accessing Canvas.
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Aug 30, 2020 - 12:13 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 30, 2020 - 11:51 MDT
Identified
Our Devops team was able to identify this issue and are working on a resolution
Posted Aug 30, 2020 - 11:41 MDT
This incident affected: Canvas (Canvas).