To view uptime history for your instance of Canvas, click here.

Some Canvas users are unable to upload files to Canvas
Incident Report for Instructure
Resolved
Our engineers were able to fix the issue and uploads should be working as intended.
Posted Nov 22, 2018 - 13:22 MST
Monitoring
Our engineers have identified the cause of the issue and have implemented a fix. We have seen improvements but will continue to monitor the behavior.
Posted Nov 22, 2018 - 13:08 MST
Investigating
We are aware of an issue that is preventing some Canvas users from uploading files to Canvas.
Posted Nov 22, 2018 - 12:50 MST
This incident affected: Canvas (Canvas LMS).