To view uptime history for your instance of Canvas, click here.

EU and UK based users are experiencing slowness within Canvas.
Incident Report for Instructure
Resolved
Performance for accounts based in the Dublin Amazon Web Services region returned to normal at 3 PM GMT yesterday (14 December) and has remained stable since that time. We continue to watch performance indicators on these accounts closely. Our DevOps team has planned a series of steps to address the root cause behind the periods of slower performance that affected these accounts over the last several days.
Posted Dec 15, 2017 - 07:22 MST
Update
Canvas users in the EU and UK are experiencing slowness and slow page loading times within Canvas. Our Operations team is continuing to investigate this issue. We appreciate your patience, and apologize for any inconvenience this is causing.
Posted Dec 14, 2017 - 05:20 MST
Investigating
Canvas users in the EU and UK are experiencing slowness and slow page loading times within Canvas. Our Operations team is currently investigating this. We appreciate your patience, and apologize for any inconvenience this is causing.
Posted Dec 14, 2017 - 04:21 MST