To view uptime history for your instance of Canvas, click here.

Canvas Support Phone calls are experiencing difficulties.
Incident Report for Instructure
Resolved
Canvas Phone Support connections have been improved and have resumed service. We apologize for any inconvenience caused.
Posted May 10, 2018 - 01:40 MDT
Investigating
We are currently investigating dropped calls or dead lines when users are trying to call into Canvas Support. Please reach out to Canvas Support via Chat window or email for improved responses. We apologize for any inconvenience caused.
Posted May 10, 2018 - 01:03 MDT
This incident affected: Support Tools (Support: Phones/Chat).