To view uptime history for your instance of Canvas, click here.

Slightly-elevated error rate in Canvas affecting some requests from users
Incident Report for Instructure
Resolved
Engineers have found and resolved the root cause of this issue. We've addressed the problem for now and will implement a change to prevent future, similar incidents in the near future. We apologize for the trouble this caused for affected users.
Posted Jun 26, 2016 - 14:48 MDT
Identified
Engineers have identified the source of the issue causing some users to see sporadic error messages in Canvas. The problem relates to a timeout-protection feature of Canvas doing what it's designed to do. We're still working to identify the cause of the long-running queries, though. We'll post another update in 15 minutes.

Note that very few users are being affected by this problem. We're tracking and aggressively trying to fix it because the timeout-error rate in Canvas right now, while still extremely low, is considerably higher than normal. Errors of this kind *can* cause users to lose data (for instance, when saving edits to a page or an assignment description or an eportfolio item), so it's a high priority for us to return the rate to normal levels ASAP.
Posted Jun 26, 2016 - 14:11 MDT
Update
DevOps have tracked the problem to a specific element of the Canvas infrastructure, but we're still working to identify the root cause. We've also identified issues with more than just eportfolios, though that's the most common area where problems are appearing. This issue is affecting a very, very low percentage of Canvas requests, but it's unusual and troublesome for those affected. We'll provide another update in 15 minutes.
Posted Jun 26, 2016 - 13:46 MDT
Update
DevOps is still investigating the eportfolio timeout errors. They've narrowed the scope of possible sources for the problem. We'll provide another update in 15 minutes.
Posted Jun 26, 2016 - 13:28 MDT
Investigating
Some Canvas users are seeing error messages when trying to access their eportfolios. Usually, refreshing will cause the eportfolio to load. Our DevOps team is investigating. We'll post an update in 15 minutes.
Posted Jun 26, 2016 - 13:15 MDT