To view uptime history for your instance of Canvas, click here.

A very small subset of users experiencing slowness and timeouts in Canvas
Incident Report for Instructure
Resolved
Performance has returned to normal. The issue causing slowness and intermittent timeouts for a small number of users has been resolved.
Posted May 26, 2016 - 09:54 MDT
Update
Our Operations team is still working to resolve the issue and we'll provide another update on our progress in 15 minutes or so.
Posted May 26, 2016 - 09:51 MDT
Identified
Our Operations team has identified the root cause and are now working to implement a solution. We hope to have this resolved as quickly as possible and will provide another update soon.
Posted May 26, 2016 - 09:38 MDT
Update
Some users continue to experience slowness and intermittent timeouts in Canvas. Our Operations team is still working to identify the cause. We'll report back again in 15 minutes.
Posted May 26, 2016 - 09:27 MDT
Investigating
Our Operations team has been alerted to slowness and intermittent timeouts affecting a small number of users in Canvas this morning. They're currently investigating the issue and we'll provide another update in 15 minutes or less.
Posted May 26, 2016 - 09:13 MDT