To view uptime history for your instance of Canvas, click here.

Users in SYD, SING, and EU regions experiencing difficulty with media files hosted in Canvas
Incident Report for Instructure
Resolved
The issue preventing users from accessing media files in Canvas has been resolved. Users can play audio and video files as normal.
Posted May 24, 2016 - 21:41 MDT
Monitoring
Our Operations team believes they've resolved the issue and will continue to monitor to ensure users are able to access media files in Canvas once again.
Posted May 24, 2016 - 21:31 MDT
Update
We've found that users in the Singapore region are also experiencing issues with media files in Canvas. Our Operations team hopes to come to a resolution soon and we'll update here as more information becomes available.
Posted May 24, 2016 - 21:10 MDT
Update
Our Operations team is still working to resolve the issue affecting media files in Canvas. We'll provide another update as soon as we have more information to report. We appreciate your patience and apologize for any inconvenience this issue has caused.
Posted May 24, 2016 - 21:02 MDT
Identified
Our Operations team has identified the cause of the issue preventing users from playing media files and they hope to have it resolved as quickly as possible. We'll provide another update soon.
Posted May 24, 2016 - 20:27 MDT
Investigating
Users belonging to accounts hosted in the SYD and EU regions are experiencing difficulty with media files in Canvas. When attempting to play them, some audio and video files become unresponsive. Our Operations team is investigating the issue and we'll be sure to provide another update in 15 minutes or less.
Posted May 24, 2016 - 20:10 MDT