To view uptime history for your instance of Canvas, click here.

Some users are experiencing slowness when accessing Canvas
Incident Report for Instructure
Resolved
Our DevOps team quickly identified the source of the longer load times and are now at expected levels. We appreciate your time and patience with this situation, and apologize for any inconvenience this may have caused.
Posted Jan 22, 2018 - 10:53 MST
Monitoring
A small number of users are experiencing longer load times than expected. Our DevOps team is currently investigating the cause, so we can implement a resolution. We apologize for any inconvenience this may be causing you, and appreciate your patience while we remedy this situation.
Posted Jan 22, 2018 - 07:29 MST