To view uptime history for your instance of Canvas, click here.

Some users are experiencing slowness
Incident Report for Instructure
Resolved
A master jobs database failed requiring a secondary database be promoted in its place. Performance for those experiencing slowness should be back to normal. We apologize for the disruption!
Posted May 18, 2015 - 09:31 MDT
Investigating
Some users are experiencing slowness when accessing Canvas. Our Operations team is working on this issue; we'll provide more information in 15 minutes.
Posted May 18, 2015 - 09:13 MDT