To view uptime history for your instance of Canvas, click here.

Some users seeing slowness and page errors
Incident Report for Instructure
Resolved
Our Operations team was able find the cause of the intermittent page errors and timeouts. All Canvas instances are now fully operational. We apologize for any trouble this has caused for you and your users!
Posted Jun 02, 2016 - 11:02 MDT
Investigating
We are currently looking into degraded performance for some users, who are seeing slowness and intermittent timeouts.
Posted Jun 02, 2016 - 10:45 MDT