To view uptime history for your instance of Canvas, click here.

Phone system currently down
Incident Report for Instructure
Resolved
Phone Support is up and fully functional.
Posted Jan 14, 2018 - 02:18 MST
Monitoring
Phone support has stabilized and calls have been coming in steadily. We will continue to monitor the situation going forward, but our ability to receive incoming calls has been restored. We appreciate your patience.
Posted Jan 14, 2018 - 01:22 MST
Investigating
We're currently experiencing an issue which is affecting our ability to receive incoming calls and provide Support over the phone. We're working with our Service Provider to investigate the issue. We apologize for any inconvenience this may be causing, please feel free to submit a ticket or contact us via Chat as we work on a resolution. We'll provide additional updates as more information becomes available.
Posted Jan 13, 2018 - 21:32 MST