To view uptime history for your instance of Canvas, click here.

A small subset of users experiencing slowness and timeouts in Canvas
Incident Report for Instructure
Resolved
Performance has been restored and appears to be stable. The small percentage of affected users should no longer be affected by the slowness and timeout errors (displayed as blank, white pages). We apologize for any trouble this has caused, and appreciate your patience as this was addressed.
Posted May 27, 2016 - 23:11 MDT
Investigating
A small number of users are experiencing slowness and timeouts in Canvas. Our Operations team is actively looking into the issue and we'll provide an update in another 15 minutes or less.
Posted May 27, 2016 - 23:02 MDT