To view uptime history for your instance of Canvas, click here.

Ongoing Intermittent Document Preview Error
Incident Report for Instructure
Resolved
Our engineering team has addressed the errors experienced during document previewing and services should now be back to normal. Thank you for your patience during this time.
Posted Nov 08, 2016 - 19:10 MST
Update
We deployed better error handling in Canvas to collect the necessary data from Crocodoc, so we can better help them identify the recent timeouts. We continue to work very closely with our partners to ensure that everything functions as intended, and we will provide updates by end of day tomorrow or sooner, based upon any new data we may receive.
Posted Nov 07, 2016 - 21:21 MST
Update
Users continue to see error messages when trying to view documents in Canvas Speedgrader. This isn't happening on every attempt to view a document, but it's happening on too many, and we sincerely apologize for the trouble this is causing—especially for teachers using Speedgrader to score submissions. Our engineers are working actively with our partners on this issue. We will provide an update at the end of the day.
Posted Nov 07, 2016 - 11:16 MST
Monitoring
We are aware that this issue is still affecting some Canvas users intermittently and are continuing our efforts to work with our partner company in order to reach a long-term solution. We apologize for any inconvenience caused and appreciate your patience. Further updates will be posted as they become available.
Posted Nov 05, 2016 - 13:57 MDT
Identified
Some Canvas users have reported further occurrences of an error being generated when trying to preview documents within Canvas. We have identified an issue that intermittently causes a connection timeout between Canvas and the Crocodoc document previewer. We are continuing to work with our partner company to ensure this is addressed. We apologize for the situation and appreciate your patience.
Posted Nov 05, 2016 - 08:25 MDT