To view uptime history for your instance of Canvas, click here.

Intermittent ability to preview documents in Speedgrader.
Incident Report for Instructure
Resolved
Amazon Web Services is now operating normally. Previewing documents in Speedgrader should be fully functional. We apologize for any inconvenience this may have caused.
Posted Aug 02, 2017 - 18:32 MDT
Monitoring
DocViewer sessions appear to be working normally but Amazon Web Services continues to experience connectivity issues. We are currently monitoring the situation to ensure that Canvas is no longer being affected by this outage.
Posted Aug 02, 2017 - 18:18 MDT
Investigating
Amazon Web Services is currently experiencing network connectivity issues. This is causing intermittently availability of DocViewer sessions in Speedgrader. Our DevOps team is aware and currently working with AWS to resolve the issue.
Posted Aug 02, 2017 - 18:03 MDT