To view uptime history for your instance of Canvas, click here.

Document rendering may take longer than normal
Incident Report for Instructure
Resolved
Document rendering time is now back to expected performance levels. We greatly appreciate your patience and apologize for the inconvenience.
Posted Dec 11, 2017 - 15:51 MST
Monitoring
The Canvas Document viewer is currently working through a large queue of requests, so some documents may take longer than normal to render. We are working to process these documents as quickly as possible. We appreciate your patience with this situation and apologize for any inconvenience this may be causing.
Posted Dec 11, 2017 - 15:40 MST