To view uptime history for your instance of Canvas, click here.

Users Affected by Temporary Service Disruption in Canvas
Incident Report for Instructure
Resolved
Our DevOps team has resolved the identified issue. Our database load times were temporarily backed up, but they were able to quickly identify several unecessary processes that could be stopped in order for normal load time to be restored. We apologize for any inconvenience this may have caused our users.
Posted Sep 24, 2015 - 14:24 MDT
Identified
Between 1:30 and 1:40 pm Mountain Time, Canvas users at various institutions noted extreme slowness in Canvas, or were unable to access the site entirely. For most users, this affected them for only five minutes or less, within the timeframe specified above. Our DevOps team were quickly able to identify the issue and most users are able to access their Canvas sites normally once again. We apologize for any trouble this has caused for you and users at your school.
Posted Sep 24, 2015 - 13:56 MDT