To view uptime history for your instance of Canvas, click here.

Wide-scale DDoS attack
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Oct 22, 2016 - 00:03 MDT
Monitoring
Wide-scale DDoS attack on critical internet services causing issues with some third-party tools in Canvas and Canvas Support’s third-party phone system

Two separate Distributed Denial of Service (DDoS) attacks on key providers of core internet services (e.g. DNS) today have caused widespread problems with many internet-based products and services (including Twitter, SoundCloud, Spotify, Shopify, and other popular websites). The first incident started early this morning and ended at about 9:30 AM ET; the second began around 12:30 PM ET and is ongoing.

Canvas itself continues to perform well. But some important third-party services in Canvas are struggling, including our document-rendering engine, which is powered by Box. Our Support team’s third-party phone system has also been affected; only some of our agents are able to log in and take calls presently.

We’re monitoring our partners’ efforts to get their tools back to running normally. We’ll post updates here as we learn more.

In the meanwhile:
Please contact our Support team using the “report a problem” link in the Help menu in Canvas or via live chat, if you’re not able to reach us by phone.

You can find a good summary of the broader issue here: https://techcrunch.com/2016/10/21/many-sites-including-twitter-and-spotify-suffering-outage/

The popular DNS provider Dyn, Inc. is among the most heavily-impacted services today; you can find their status page here: https://www.dynstatus.com/incidents/nlr4yrr162t8
Posted Oct 21, 2016 - 12:18 MDT
Identified
Currently 3rd-party Canvas services are experiencing a large DDoS (Distributed Denial of Service) attack. The below features will be slow or unavailable and will show as loading within Canvas. This has also affected our Phone system so please contact us via the chat and help links within your Canvas Instance. For more information please see: https://techcrunch.com/2016/10/21/many-sites-including-twitter-and-spotify-suffering-outage/
Posted Oct 21, 2016 - 11:43 MDT
Investigating
We are currently experiencing problems with our phone system, while we are investigating this please feel free to chat with us, file an online case via the help menu, or email support@instructure.com. Thank you for your patience while we investigate.
Posted Oct 21, 2016 - 11:03 MDT