To view uptime history for your instance of Canvas, click here.

Phone Support Calls Not Going Through
Incident Report for Instructure
Resolved
All phone lines are now available and working again. Please send us an email or chat to let us know if you encounter any further problems contacting us by phone.
Posted Aug 25, 2015 - 20:51 MDT
Investigating
ThinkingPhones is currently experiencing difficulties with their phone system. This is preventing your calls from coming to us. You can still contact us through your Chat link, using the Help link inside Canvas, or emailing us at support@instructure.com. We will keep you updated on the progress. We apologize for the inconvenience.
Posted Aug 25, 2015 - 20:40 MDT