To view uptime history for your instance of Canvas, click here.

Some Users Experiencing Slowness in Canvas
Incident Report for Instructure
Resolved
Some users experienced mild slowness in their Canvas site between 12:20 pm and 12:50 pm MDT. During this time, pages within the site may have taken a little longer to load, but users were still able to access those pages successfully after a few seconds. Our DevOps team has identified and addressed the issue, and Canvas should now be loading normally for these users once again.
Posted Apr 11, 2016 - 12:57 MDT
Investigating
A small amount of users may be experiencing slowness in Canvas. Our DevOps team is investigating the cause of this behavior. We'll post an update in 15 minutes.
Posted Apr 11, 2016 - 12:48 MDT