To view uptime history for your instance of Canvas, click here.

Some users experiencing slowness in Canvas
Incident Report for Instructure
Resolved
Performance has returned to normal for all Canvas users. We apologize for the slowness you and your users experienced this morning. We'll work with AWS to learn more about what happened and what they'll do to avoid / mitigate similar issues down the road.
Posted Nov 21, 2014 - 08:46 MST
Monitoring
Our DevOps team has worked with Amazon Web Services on this issue; they've determined that a systemic issue provisioning new hardware in AWS was preventing Canvas from scaling resources automatically in response to increasing demand this morning. AWS indicates the problem has been resolved, and you should quickly see performance return to normal. We'll post an update when the issue is fully cleared; hopefully in the next few minutes.
Posted Nov 21, 2014 - 08:34 MST
Investigating
We're observing slow performance in some instances of Canvas currently. Our DevOps team is investigating; preliminary indications are that this is an issue across Amazon Web Services and is impacting more than just Canvas. We'll provide an update in the next 15 minutes.
Posted Nov 21, 2014 - 08:23 MST