To view uptime history for your instance of Canvas, click here.

Slowness for Canvas users in accounts hosted in the Dublin AWS data center
Incident Report for Instructure
Resolved
Our DevOps team has notified us that the server performance is back to normal levels now. We will be monitoring this situation carefully, and we’ll provide further updates if there are any signs of disruption.

We cannot thank you enough for your patience through this situation. We sincerely apologize for any inconvenience this may have caused you and your users.
Posted Feb 09, 2017 - 10:51 MST
Update
Our Operations team is is still investigating the root cause of the slowness. The previous update did not have the results we had hoped for. We are monitoring this update and will post more information as it becomes available. Thank you for your patience.
Posted Feb 09, 2017 - 09:05 MST
Monitoring
Our Operations team is working diligently to resolve this situation. We are currently implementing an update that will hopefully resolve any lingering slowness, and page time outs. We are monitoring this update and will post more information as it becomes available. Thank you for your patience.
Posted Feb 09, 2017 - 08:44 MST
Update
Our engineers are continuing to investigate slowness and page errors that are affecting a small number of Canvas users. Our Ops team is dedicating all their resources to a resolution and we will continue to post updates as they become available. Thank you for your patience.
Posted Feb 09, 2017 - 07:54 MST
Investigating
We are still receiving lingering reports of slowness for users on accounts hosted in the AWS Dublin data center. We are re-opening this status, and we will continue to monitor the situation. Our Ops team is aware of this situation and are working to resolve the slow performance.
Posted Feb 09, 2017 - 07:23 MST