To view uptime history for your instance of Canvas, click here.

Users experiencing issues accessing content in Commons
Incident Report for Instructure
Resolved
A fix has been deployed for the issue preventing users from accessing content in Commons. Commons Functionality has now returned to normal.
Posted Sep 26, 2016 - 10:11 MDT
Update
Our team is still working to resolve the issues users are experiencing when attempting to access Commons. We will continue to post updates when we have them. We apologize for any inconvenience this may be causing.
Posted Sep 26, 2016 - 09:20 MDT
Investigating
We are looking into an issue that is causing users to receive a 404 error when attempting to access content within Commons. We will provide updates as information is made available to us.
Posted Sep 26, 2016 - 07:56 MDT