To view uptime history for your instance of Canvas, click here.

Some users experiencing slowness and page errors in Canvas
Incident Report for Instructure
Resolved
Canvas is now performing normally for all users. We apologize for the slowness and page errors some users observed over the last two hours. Of the small percentage of Canvas users affected by this issue at all, the great majority were affected for only 23 minutes (2:18 AM MT to 2:41 AM MT); the remaining very small group of users experienced an extended incident that was resolved moments ago. We will provide a detailed incident report to Canvas admins at affected institutions on Monday.
Posted Feb 07, 2015 - 04:27 MST
Investigating
A small percentage of Canvas users are seeing degraded performance in Canvas currently. These users are sometimes experiencing slow page loads; sometimes, page loads are failing entirely and users are seeing error messages. Our DevOps team is working on the problem.
Posted Feb 07, 2015 - 02:30 MST