To view uptime history for your instance of Canvas, click here.

Some users experiencing slowness in Canvas
Incident Report for Instructure
Resolved
Our DevOps team has addressed the database performance issues that were causing slowness in Canvas for some users. Performance is back to normal for all users.
Posted Feb 02, 2015 - 10:18 MST
Identified
A small percentage of Canvas users are experiencing slowness currently. Our DevOps team is working on it, and we'll provide an update in 15 minutes. Sorry for the trouble!
Posted Feb 02, 2015 - 10:05 MST