To view uptime history for your instance of Canvas, click here.

Slowness with UK instances of Canvas
Incident Report for Instructure
Resolved
Our Ops team has remedied the slowness and timeouts that was affecting some of our Canvas users. We'll continue to investigate the cause to ensure that this behavior does not continue. We appreciate your patience with this situation, and sincerely apologize for any inconvenience this may have caused.
Posted Feb 09, 2017 - 06:29 MST
Update
Our Ops team is continuing to investigate the cause of the timeouts that affected the UK Region of Canvas users. We are continuing to monitor their progress, and will update the status page as that information becomes available.
Posted Feb 09, 2017 - 06:19 MST
Identified
Our Ops team has identified the trouble and are working to resolve it.
Posted Feb 09, 2017 - 05:39 MST
Investigating
Schools in the UK region are seeing slowness resulting in timeouts this morning, our Ops team are investigating the cause, we will update this every 15 minutes until resolved.
Posted Feb 09, 2017 - 05:19 MST