To view uptime history for your instance of Canvas, click here.

Intermittent network connectivity issues
Incident Report for Instructure
Resolved
We have received confirmation from Amazon that they have resolved the network latency issues with one of their top level network providers. We have furthermore confirmed with customers who had previously reported issues, that they are not longer experiencing packet loss or latency.

If you encounter any lingering network connectivity issues, please feel free to contact Instructure support at http://help.instructure.com
Posted Feb 19, 2015 - 15:20 MST
Monitoring
We have been notified by our cloud hosting provider, Amazon, that they are currently experiencing and triaging network connectivity issues with some of their top level network providers. We are working closely with Amazon to analyze the impact to our customers and have determined that a very small percentage of customers have been impacted.

Amazon is working with their top level network providers to redirect traffic around the troublesome nodes, and we will update as soon as we receive the all clear from them.
Posted Feb 19, 2015 - 13:39 MST